Summary
This article provides a hotfix for some retired versions of InstallShield.Symptoms
After activating your InstallShield product, each time the InstallShield product is opened it again prompts for activation. This is known to occur with some older versions of InstallShield that use an older activation technology.
Cause
This behavior may be caused by a known limitation in this older activation technology being used in these versions of InstallShield, and is likely to occur more frequently on machines with RAID arrays.
This behavior no longer occurs in InstallShield 2008 and later versions due to a newer activation technology being used.
Resolution
A hotfix is available that has resolved this behavior on some machines. Follow the steps below to apply this update:
- Download the hotfix.
- Browse to the following location: C:\Program Files\Common Files\InstallShield Shared\Service.
- Make a backup copy of the current version of "InstallShield Licensing Service.exe" located in this folder.
- Extract the hotfix zip file, and copy the updated version to this location to overwrite the original version.
- Close the InstallShield product that prompts for activation and re-open it.
It should now prompt for activation initially, then no longer prompt once it's activated successfully.
Additional Information
This article applies to InstallShield 12.x and earlier , AdminStudio 8.5 and earlier , InstallShield 12 Express and earlier , and DemoShield 8.x and earlier.
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