Symptoms:
Since the ExcludeDirectory value is coming from policy to be used to apply configuration locally on a machine, the agent overwrites any previous values in config.ini if it is present in the policy which overwrites custom exclusions
Diagnosis:
There is no way to stop the agent from doing this at this time for Agents get most of their configurations through policy.
Solution:
If you do not want any value for exclude directory set in policy, you will need to remove the policy property from the BeaconTargetPropertyValue_MT table as the Inventory Settings page on the FNMS UI seems to set an empty value if the include directory or exclude directory was previously set.
Note, as such, this is not an issue with the FNMS agent but the inventory settings UI.
This workaround is for On-premise customer's only, for it'll require updating the FNMS database
- To find configured policy values run the following query:
SELECT [BeaconTargetPropertyID]
,[BeaconTargetID]
,[KeyName]
,[Value]
,[TenantID]
FROM [FNMP].[dbo].[BeaconTargetPropertyValue_MT]
ORDER BY [FNMP].[dbo].[BeaconTargetPropertyValue_MT].BeaconTargetID - Deleting any records where KeyName is CTrackerExcludeDirectory (and the BeaconTargetID links to 'target__unix' in the BeaconTarget_MT table)
- Then running 'UPDATE BeaconPolicy SET RevisionNumber = RevisionNumber + 1' will remove the exclude directory from the beacon policy, and then agent policy.
Note that the cached device configuration contents.ndc on an agent device will cause the 'original' value to be restored to config.ini on the next policy run after exclude directory is removed from the FNMS db policy properties. If this is not desired, the 'cache' and 'pkgcache' directories on the agent machine in /var/opt/managesoft/launcher should be deleted and then policy reapplied.
Also note that if the Inventory Settings page in the FNMS UI is saved again, the exclude directory property will be added to BeaconTargetPropertyValue_MT again, requiring the above workaround to be applied to remove it.
On going enhancement to locally preserve ExcludeDirectory configurations for Unix-like devices:
Enhancement# IOJ-2119539
Related Articles
Locally configured ExcludeDirectory settings get overwritten by agent policy update even if no exclusions are specified in… 4Number of Views FlexNet Inventory Agent Status page shows current agent version in the "Policy specifies" column for all devices with oper… 4Number of Views Inventory Settings page in the web UI inappropriately indicates "$(ProgramFiles(x86))" is an "Invalid folder name" when co… 4Number of Views Known Issue: Downloading policy or client settings may fail when an agent is configured to use an IPv6 address to connect … 10Number of Views Agent policy download from beacon fails with HTTP 400 BAD REQUEST response unless machinename and ipaddress are both speci… 6Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago