Summary
Manifest Compatibility Section Missing from Setup Manifest May Lead to Program Compatibility Assistant DialogSymptoms
On Windows 7 and Windows Server 2008 R2 operating systems, the following Program Compatibility Assistant (PCA) dialog may appear at the end of an installation:
Cause
Microsoft implemented a new Program Compatibility Assistant rule to detect when an installation does not finish successfully.
Steps To Reproduce
This warning will be displayed if the installation fails to complete successfully, is canceled by the user, or does not create an entry in the Add and Remove Programs Control Panel.Resolution
To avoid this warning dialog, define a compatibility section in the appropriate Setup.exe manifest file that configures the installation to be excluded from Program Compatibility Assistant (PCA) interference.
The compatibility section that needs to be added is as follows:
<compatibility xmlns="urn:schemas-microsoft-com:compatibility.v1">
<application>
<supportedOS Id="{35138b9a-5d96-4fbd-8e2d-a2440225f93a}"/>
<supportedOS Id="{e2011457-1546-43c5-a5fe-008deee3d3f0}"/>
</application>
</compatibility>
For your convenience, SetupExe.*.manifest files that have been modified to contain this section can be downloaded from the Attachments section of this Knowledge Base article.
The modified SetupExe.*.manifest files should be placed in the InstallShield product Support folder. Please make a backup of the original SetupExe.*.manifest files before editing or overlaying them with the attached files. Depending on the edition of InstallShield, the default location for the <InstallShield Product>\Support folder is:
-
Express or Professional or Premier
-
C:\Program Files\InstallShield\2010\Support
-
-
Standalone Build
-
C:\Program Files\InstallShield\2010 StandaloneBuild\Support
-
After the modified Setup.exe manifest file changes are in place, rebuild the installation.
Additional Information
To read more about the Program Compatibility changes for Windows 7, please refer to MSDN's Blog on PCA Changes.
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