Summary
InstallValidate action unable to automatically close all requested applications
Symptoms
The InstallValidate standard action in a verbose runtime log indicates:
MSI (c) : RESTART MANAGER: Session opened.
MSI (c) : Note: 1: 2262 2: ListBox 3: -2147287038
Action: ShutdownApplications. Shutting down applications
MSI (s) : RESTART MANAGER: Failed to shut down all applications in the service's session. Error: 351
MSI (c) : RESTART MANAGER: Successfully shut down all applications that held files in use.
MSI (s) : Note: 1: 1611
The setup was unable to automatically close all requested applications. Please ensure that the applications holding files in use are closed before continuing with the installation.
MSI (s) : RESTART MANAGER: The user chose to go on with the installation, although a reboot will be required.
The installer package was unable to automatically close all requested applications. Please ensure that the applications holding files in use are closed before continuing with the installation.
Cause
The InstallValidate action is a standard Windows Installer action. As such, details about what it does beyond documentation in the Windows Installer SDK is outside of our support. When this behavior occurs we may not be able to provide any insight into what causes this behavior.
Resolution
- Perform MSI validation and resolve the conflicts.
- If MSI validation-resolution of your MSI does not produce expected runtime behavior include the MSIRESTARTMANAGERCONTROL property in the Property Table of your package. When creating this property set its value to "Disable".
- If this does not seem to improve the behavior, you may try contacting Microsoft directly for additional assistance.
Workaround
There is no native support to deal with Restart Manager and you may consider the suggestion in these third party articles to leverage restart manager:
Windows Installer and Restart Manager: MSI Files-In-Use V2
The following suggestion involves a Google search for an article on the Code Project website with an interesting approach to resolve the situation. Search for and investigate if this third party solution meets your needs:
How to Develop Restart Manager Aware Application: Test Case 30
Related Articles
Basic MSI Installer That Uses Billboards Exits Without Error When Run on Unsupported OS Architecture 3Number of Views How To Build a Compressed Single MSI Installer 12Number of Views Create a New Windows User with an MSI Installer without user input. 4Number of Views Unable To Install Snow Inventory Agent - Network Resource Unavailable - CCMCache Error 68Number of Views ADDM import fails with the error ?Unable to read data from the transport connection: The connection was closed.? 31Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago