Summary
This article discusses the issue with running Project Automation Java class with 64-bit JDK which results in the project failing to be saved by a node-locked licensed copy of InstallAnywhere.Symptoms
Running the Project Automation Java class with a 64-bit JDK results in the project failing to be saved by a node-locked licensed copy of InstallAnywhere.
Here is the error message that's generated:
Trying to checkout IAEB version=17.0 Library for Native Hostid Couldn't Be Loaded (-521,7024) Trying to checkout IACB version=17.0 Library for Native Hostid Couldn't Be Loaded (-521,7024) Trying to checkout IAEE version=17.0 Library for Native Hostid Couldn't Be Loaded (-521,7024) Trying to checkout IACE version=17.0 Library for Native Hostid Couldn't Be Loaded (-521,7024) Trying to checkout IAEJ version=17.0 Library for Native Hostid Couldn't Be Loaded (-521,7024) Trying to checkout IACJ version=17.0 Library for Native Hostid Couldn't Be Loaded (-521,7024) Trying to checkout IAS version=17.0 Library for Native Hostid Couldn't Be Loaded (-521,7024) This copy of InstallAnywhere could not be registered using the node locked licensing file specified.Please check if the license file specified at (<path_to_lic_file>) is a valid license file for this node.If this was a subscription license, please verify if your license has expired.
Cause
InstallAnywhere is shipped as a 32-bit application, and the libraries which are used are only compatible with a 32-bit JVM.Steps To Reproduce
1. Create a project.2. Implement a Project Automation Java class. For example:
package com.zerog.ia.projectautomation;
import com.zerog.ia.auto.project.Project;
import com.zerog.ia.auto.project.ProjectAutomation;
public class TestInstallAnywhereAutomation
{
public static void main(String[] args)
{
try
{
System.out.println("Test start...");
ProjectAutomation.setIALocation("C:\\Program Files (x86)\\InstallAnywhere 2015 Premier");
System.out.println("IALocation set");
Project myProject = ProjectAutomation.loadProject("C:\\Users\\UserName\\Desktop\\ProjectName\\ProjectName.iap_xml");
System.out.println("Project loaded");
System.out.println("java.library.path is : " + System.getProperty("java.library.path", ""));
System.out.println("Test IA auto api");
System.out.println("IA project file to modify is " + "C:\\Users\\UserName\\Desktop\\ProjectName\\ProjectName.iap_xml");
ProjectAutomation.saveProject(myProject);
System.out.println("Project saved");
System.out.println("Test done...");
}
catch (Exception e)
{
e.printStackTrace();
System.exit(-1);
}
System.exit(0);
}
}
3. Compile the Java class.
4. Export the Java class in a JAR file.
5. Run the Project Automation Java class with a 64-bit JDK.
The Project Automation Java class successfully loads the project but fails to save the project.
?
Resolution
Use a 32-bit JDK when running the Project Automation Java class.Additional Information
An enhancement request for 64-bit support has been submitted to our Engineering team as Issue# IOJ-1748232. Our Engineering team is investigating this issue, but at this moment, there is no estimated time frame for when this feature will be implemented.Was this helpful?
Related Articles
Project Automation API InstallDirectory 3Number of Views Using Project Automation to Configure InstallAnywhere Project Files 4Number of Views FNO 2022.R1 installation failed with latest Java JDK on Windows Server 2022 10Number of Views How to change the version of each component to 64bit in InstallShield using IS IDE and Automation script 5Number of Views Set All Component 64bit Option to “YES “ Using Installshield Automation Interface Script 11Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago