Summary
When scheduling a report using Report Designer (Cognos) this fails with "CM-REQ-4159 Content Manager returned an error in the response header." error message.Symptoms
When Scheduling a report using Report Designer (Cognos) this fails to send and the following error message can be seen in the "Run History" of the report. This error can be seen when using Report Designer 10.2 with FlexNet Manager Suite and was not present when using version 10.1.
Error:
"CM-REQ-4159 Content Manager returned an error in the response header. The error "cmAuthenticateFailed CM-CAM-4005 Unable to authenticate. Check your security directory server connection and confirm the credentials entered at login." can be found in the response SOAP header. CM-REQ-4342 An error occurred with the client"
Cause
This error message is caused by a known issue with the authentication of the Cognos roles.Workaround
The attached file can be used to resolve the issue and applied using the steps below:
-Download "FlexnetAuthenticationProvider-15.0-Schedule" from the KB.
-Stop the "IBM Cognos" service.
-Browse to the following directory "c10\webapps\p2pd\web-inf\lib".
-Backup the current "FlexnetAuthenticationProvider-15.0.jar".
-Replace the file with the file "FlexnetAuthenticationProvider-15.0.jar" file extracted from the downloaded zip.
-Restart the "IBM Cognos" service and test the issue.
Additional Information
If this error is seen when using FlexNet Manager for Engineering Applications please upgrade to version 15.5 Patch 1.
Related Articles
How To Troubleshoot Report Designer/IBM Cognos Analytics Errors? 8Number of Views Report Designer Cognos reporting package importing fails if Report Designer is running on the different computer from FNMP… 6Number of Views QE-DEF-0285 error when generating a Report Designer report 12Number of Views FAQ: Unable to select email when Scheduling a report in Snow License Manager 18Number of Views How to reset the Flexera Analytics (Report Designer) Content Store database? 9Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago