Summary
The Spider setup reported an error during the prerequisites check for the SQL server.
Current Spider version is 6.4.x.
Cause
This can by caused by one of the following issues.
- SQL Server Version is not within the allowed range
Resolution
The SQL Server requirements are shown below.
- Spider 6.4
- Microsoft SQL Server 2012 or newer
- Spider 6.3
- Microsoft SQL Server 2008 or newer
- Spider 6.2
- Microsoft SQL Server 2008 or newer
- Spider 6.1
- Microsoft SQL Server 2008 or newer
- Spider 6.0
- Microsoft SQL Server 2005 or newer
- Recognition
- Microsoft SQL Server 2008 or newer
- Recommended Version:
- Microsoft SQL Server 2016 Standard (64bit)
- Supported Versions
- Microsoft SQL Server 2019
- Microsoft SQL Server 2016
- Microsoft SQL Server 2014
- Microsoft SQL Server 2012
- Microsoft SQL Server 2008 / 2008 R2*
- Supported Editions**
- Standard - for single Mandator environments
- Enterprise - for multi Mandator environments
- Express - for very small environments, please note some restrictions apply
- Required Settings
- TCP/IP protocol has to be enabled
- Named Pipes protocol has to be enabled
- Installation requires "SQL Server and Windows Authentication mode" to be enabled, After the first installation you can switch the SQL Server to "Windows Authentication mode"
* Versions 2008 / 2008 R2 will no longer be supported by Spider 6.4 or better.
** Always On Availabilty Groups are not supported
Additional Information
If you choose to provide databases and not let them be created through the setup, please note the following important points.
- The names of the databases can be chosen individually, the name may not begin with a digit.
- The names of the databases can be chosen individually, the name may not contain the following characters: - \ / " | <> : * ? ] [ + = ; , @ & .
- The names of the databases can be chosen individually, the name may not contain unicode characters.
- The names of the databases can be chosen individually, the name may not exceed
- 50 (Spider version older than 6.4.7 R3) characters.
- 128 (Spider versions newer than 6.4.7 R2) characters.
- All databases have to have the same collation. It has to be a case insensitive (CI) collation, e.g. SQL_Latin1_General_CP1_CI_AS
- All databases for installation have to be completely empty
- The name for the Spider Core Temp database has to be <SpiderCoreDBName>_TempDB, e.g. SpiderCore_TempDB
- The name for the Spider Session State database has to be <SpiderCoreDBName>_SessionState, e.g. SpiderCore_SessionState
Was this helpful?
Related Articles
Spider Setup: System Requirements - SQL server verify sql user database authorization 6Number of Views Spider Setup: System Requirements - SQL server get available all database names 5Number of Views Spider Setup: System Requirements - SQL execute permissions on database msdb 19Number of Views Spider Setup: System Requirements - SQL permission to create sql users 5Number of Views Spider Setup: System Requirements - Microsoft .Net 9Number of Views
Revenera Assistant - Beta
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago