Summary
When performing an upload from an Inventory Beacon to another Beacon or the Inventory server running Windows 2008 Server this fails and the following information can be found in the upload.log log file.Symptoms
When performing an upload from an Inventory Beacon to another Beacon or the Inventory server running Windows 2008 Server this fails and the following information can be found in the upload.log log file.Error 0xE0500016:
Error 0xE050044D: Failed to create remote directory /ManageSoftRL
Error 0xE0690099: Specified remote directory is invalid, or could not be created
ERROR: Remote directory is invalid
Ignoring failover locations for upload on a distribution server
Uploading finished
************************************************************
Program exited with code 1
In addition to this the following line will also appear in the Internet Information Services (IIS) log file on the server where the upload is taking place.
MKCOL /ManageSoftRL - 443 - 10.193.156.237 Enterprise+Deployment+Suite/8.6+(Windows+x86) 401 2 5 31
The HTTP 401 error in bold confirms the authentication error when uploading to the upload location "ManageSoftRL"
Cause
This is caused by the way IIS 7 shipped with Windows Server 2008 handles Anonymous Authentication, this is prohibited for file uploads and WedDAV for all domains, and has been updated from previous versions of IIS. More information on how this can be found below:Specifically:
o Anonymous PROPFINDs are allowed for file listings, but file uploads and WebDAV-based GET requests require an authenticated user. This is a change from IIS 6.0, where anonymous WebDAV file uploads/downloads could be enabled by opening up your security. In WebDAV for IIS 7.0 we changed this behaviour so that all WebDAV activity would require authentication, but we allow for the use of anonymous PROPFINDs for backward-compatibility with some WebDAV clients. (More specifically, the PUT, MKCOL, PROPPATCH, COPY, MOVE, DELETE, and WebDAV-based GET requests all require authentication.)
Resolution
The following information describes steps on how to identify and resolve the issue.Identification:
1. Confirm if the servers are on different domains or the same domain by reviewing the system information.
2. Compare the IP address from the server to the IIS log and confirm there is an issue uploading to "/ManageSoftRL" and the HTTP 401 error is present.
Resolution:
Servers on the same domain:
1. Enable Integrated Windows Authentication (IWA).
2. Disable Anonymous Authentication.
Servers on a different domain
1. Enable ASP.NET Impersonation on the server, IWA cannot be used as the credentials will not be recognised by the domain controller.
2. Set the account under which this runs to a be service account which will also have access to the database.
3. Disable Anonymous Authentication.
Alternatively Basic Authentication could be enabled but this will display any usernames and passwords in plain text and is not recommended.
Additional Information
The information contained in this article does not apply to FNMS 2014 or above as the reliance on WebDAV was removed in 2014. Therefore this article only applies to Inventory Manager 9.2.3 and below.Was this helpful?
Related Articles
How to configure replication to collect a uploaded agent files on the FlexNet Manager Suite inventory server 42Number of Views Inventory Beacon fails to upload packages to FlexNet Manager Suite Cloud, error is "The remote certificate is invalid acco… 55Number of Views Beacon fails to upload large inventory files 14Number of Views Configure Distribution Server/Inventory Beacon to use Web Handlers for File Uploads 12Number of Views Configure a task to upload inventory files from older version beacon servers 20Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago