Summary
This knowledge base article will describe a product defect of content library ARL import issue which cause the following library SKU , PURL not being uploaded.Symptoms
User may observe from system dashboard that SKU & PURL library updated date is older than ARL library. See below screenshot of samplePlease be advised , the current product limitation includes:
1. There is no failure message of ARL import failure
2. There is no alert message of SKU/PURL not being updated due to ARL import failure
3. There is no seperation import mechanism at this stage that if ARL import fails, SKU or PURL will start importing independantly.
Cause
The cause of other two LIbrary not being updated can be the defected recently identified in ARL import with version v2145. It was released on 22nd of June 2017.
For On Premise customer
1. Check ARL import failure Please check below SQL table
SELECT * FROM SoftwareRecognitionImport
ORDER BY 1 DESC
if the Failure Reason is about similar message "SQL Server returned error code 2627 : line: 71 Violation of UNIQUE KEY constraint 'UQ__#Upgrade__A9B787AF38CE4EA6'. Cannot insert duplicate key in object 'dbo.#UpgradeDowngradeSoftwareTitles'. The duplicate key value is (14354, -122219, 2, 2). Note: This file should not be executed manually. For manual ARL execution please call mgsImportRecognition.exe."
Then your system has been impacted by the defect of ARL script released in v21145.
Resolution
Please import any newer ARL version released at or after 29th of July 2017 (any ARL version from v2159 or later)It will solve the ARL import failure. Consequntely your SKU and PURL will be updated accordingly.
If even ARL with latest version has been imported successfully ,but your SKU or PURL are still not updated. Please collect the PURL.log from user temp and send them to Flexera Support for further investigation.
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Case id: 00001065
Activity: Status change: 2 hours ago