Summary
The file cannot be installed because the file cannot be found in the cabinet file.
Symptoms
When running an InstallShield Express setup, the following error may occur:
Error -1334: The file [2] cannot be installed because the file cannot be found in the cabinet file [3]. This could indicate a network error, an error reading from the CD-ROM, or a problem with this package.
[2] and [3] are placeholders where information specific to the error appears.
Cause
This is a Microsoft error that might occur in any of the following scenarios:
- The previous version of the package that was installed is still cached on the system. This can happen if a new version of the same package (same Product Code and Package Code) is modified and run without completely uninstalling the old package from the system. For additional information on caching, see the Additional Information section below.
- A compressed release has been built incorrectly (for example, there are missing files).
Resolution
- If a previous version of the package is still cached on the system, remove it:
- Run the uninstallation of the package on the system if it is still present.
- Verify that both uninstall keys are removed from the system by launching the Registry Editor (by typing regedit in the Start | Run dialog) and checking the following registry keys:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\<PRODUCTCODE> HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\InstallShield_<PRODUCTCODE>If you find the keys, manually delete them.
- Generate a log of the installation that fails with run-time error 1334. See the Additional Information below for details on creating a log file.
- Find the value of the DATABASE public property in the log file. It should provide the location of the cached .msi package.
- Delete the cached package.
- In the future, make sure that the package is properly uninstalled using Add/Remove Programs before installing a modified version.
- If building a compressed release, delete the release before building again. This recreates the release and resolves any errors if the package was incorrectly built initially. This can be done by using the "Open Release Folder" option from the Tools menu to open the build location, and delete all files within this folder.
It also may prove helpful to build the release as uncompressed to verify if this error still occurs. Building as an uncompressed release may be a suitable workaround to this error as well.
Additional Information
Caching
Microsoft uses caching to store a backup copy of an MSI package on the target machine. This backup copy is used during maintenance mode, when repairing or modifying the existing installation. Without this cached copy, the setup prompts for the original media each time maintenance mode is used. By default, Microsoft randomly renames the MSI package and places it in the following hidden location:
<WINDOWSFOLDER>\Installer
For example, on a Windows 2000 machine, this location is:
C:\WINNT\InstallerRelated Articles
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Case id: 00001065
Activity: Status change: 2 hours ago