Summary
Error -1334: The file [2] cannot be installed because the file cannot be found in the cabinet file [3]. This could indicate a network error, an error reading from the CD-ROM, or a problem with this package.Symptoms
When running an installation created with InstallShield Express, the following error message occurs:
Error -1334: The file [2] cannot be installed because the file cannot be found in the cabinet file [3]. This could indicate a network error, an error reading from the CD-ROM, or a problem with this package.
[2] and [3] are placeholders where information specific to the error appears.
Cause
There are several factors that can cause error 1334 at run time. The following is a list of all possible causes known to produce this error message.
- When sending an upgrade to an existing setup, this error can occur if the upgrade is not authored properly.
- A compressed release was not built properly or has become corrupted.
- One or more dynamically linked files are missing from their source location while the build is being generated.
- The file referenced in error 1334 may not be linked properly in the project. Internally, the file may be missing its link, which may not be apparent from the Express IDE.
- In some cases, this issue has been reported when the build is generated on a corrupt machine.
Resolution
Follow these steps to resolve error 1334. The resolutions are in the order in which the causes appear above:
- If creating an upgrade, you must either create a major upgrade, minor upgrade, or a patch. A major upgrade requires that you change the product code of the setup, not doing so can cause error 1334. Make sure that your upgrade is authored properly if this error occurs during an upgrade. The following articles discuss the process of creating an upgrade successfully:
- Sending an Upgrade Using Upgrade Paths
- Sending a Minor Upgrade to an Existing Product Without Uninstalling/Reinstalling
- Changing the Package/Product/Upgrade Code and Version Number for Upgrades
- Sending an Upgrade Using Upgrade Paths
- If the error occurs with a compressed release, create an uncompressed release to see if that fixes the issue. If creating an uncompressed release fixes the issue, delete the old compressed release from the location where it is being built and generate a new compressed release.
- Look for the file specified by error 1334 in one of your dynamically linked folders within the project. If the file appears to be present, launch Windows Explorer and look for this file in its source location. Make sure that the file is present. Also make sure that it is not read-only. You can check the read-only attribute of a file by right-clicking on it and selecting Properties.
- If the error occurs for a file that is linked statically in the project, make sure that its link is not missing. The best way to ensure this is by deleting the file from the project and reinserting it into the project. This way a new link is created for the file within the project.
- There have been some cases where this issue has occurred because of a corrupt build machine. To determine if your build machine is corrupt, create a test project in Express and see if the same error occurs. Make sure that the test project is as simple as possible while it is identical to your original project in logic. If the error continues to occur with any project created on this machine, try installing Express on another machine and build from there. If that works, contact your system administrator to have your system fixed.
Additional Information
For further troubleshooting, you may want to log the installation. To log an Express-based installation, see Knowledge Base article Logging an Express Installation
This error is briefly documented in the Windows Installer Help Library topic Windows Installer Error Messages.
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Case id: 00001065
Activity: Status change: 2 hours ago