Summary
This article contains information about Windows Installer errors.
Symptoms
When an InstallShield installation is run, the following error occurs at run time:
Error -1706: No valid source could be found for product [2]
[2] contains the name of the product that could not be found. It may also prompt with a browse window that allows you to browse to the original MSI package.
Cause
This error is a Microsoft Windows Installer error and has been known to occur when the source files for the running setup cannot be found by the installer. This error is typically encountered during Maintenance Mode when the Modify or Repair options are selected. In most cases, the caching of the Windows Installer package by Windows Installer engine the seems to fail for Compressed builds or a Web Download Release.
Resolution
The following solutions have been known to resolve this error in many cases:
- If a browse dialog appears, and the setup is being installed from the web, make sure the setup.exe file is looking in the correct location for the MSI package. This location is specified in the Release Wizard and should contain the URL to the web server that contains the MSI package to be downloaded.
- Cache the setup files so the installer can locate them at all times. This option is only available for setups where the MSI package is extracted from the setup.exe (i.e., any compressed builds) or where the MSI package is downloaded by setup.exe (i.e., Web builds). To do this, follow these steps:
- Select the Releases view.
- Select the specific Release being used.
- Set the Cache Web Download property to a value of Yes.
- Rebuild the release.
- If installing the setup from a network location, make sure you have full read/write/execute access to the necessary network locations.
- Upgrade to the latest version of InstallShield.
- Verify that full administrative privileges are granted on this Windows machine.
- Use the Release Wizard to build a new release with a new release name.
Additional Information
Note for users of Windows Vista: The article discussing the administrative policy AllowLockdownMedia states that, 'the default value of this policy is 1 only on computers running Windows Vista and that are not joined to a domain.' However, it has been reported that this may not be accurate in all cases resulting in an un-set property. The net effect is that (1) installing a package from removable media like a CDROM, maintenance mode cannot be run and (2) the package cannot be uninstalled. Flexera Softare has reported this issue to Microsoft and they are considering possible resolutions. Setting this policy should resolve the behaviour.
Additional information on error 1706 can be found in these Microsoft articles:
- 258847 "The feature you are trying to use is on a network resource that is unavailable" or "Error 1706"
- 268800 FIX: Windows Installer Must Have Original Source Files When You Apply a Patch
- Preventing a Patch from Requiring Access to the Original Installation Source
The behavior is also discussed under these headings in the Microsoft Technet article Windows Installer FAQ:
- How can I prevent my patch from requiring the source?
- When will patches require the original source?
Additional information on error 1706 as applied to patching can be found in these InstallShield and InstallSite.org articles:
- InstallSite.org - How to Apply a Patch Without Source
- InstallShield - Q106362 Successfully Authoring a Patch
- InstallShield - Q107297 Windows Installer Error 1706
This error is mentioned in the MSI Help Library topic Windows Installer Error Messages .
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Case id: 00001065
Activity: Status change: 2 hours ago