Summary
This KB article helps to resolve the issue - A transport-level error has occurred during Compliance ImportSymptoms
The Compliance Import can fail with an error similar to the one below:
A transport-level error has occurred when sending the request to the server. (provider: TCP Provider, error: 0 - An established connection was aborted by the software in your host machine.)
FATAL: Import failed.
FATAL: Import failed.
Cause
A transport level error such as this usually means that the connection from the FNMP server and the database has dropped unexpectantly. This can be caused by a number of things and is usually just a one-off and so will complete when the compliance import next runs. If it keeps occurring then you will need to investigate what is happening, in over 90% of the cases where this error occurs on a regular basis the problem is caused by either DB maintenance or Network maintenance occurring at the time when the import is running.
Resolution
Each environment has its own setup / tasks and so what we recommend is investigating what takes place in your environment round that time and then either stopping it for a day or changing the Compliance Import time temporarily to see if that resolves the issue. Some general suggestions of what to look for are:
-
Is the database on the same server as FNMP or on a different server? If on the same server then network problems are not an issue, if they're on different servers then network problems could be an issue.
-
In Windows scheduled tasks look for the task "Import ManageSoft Compliance data sources" and check what time it runs (default is 2am), then ask your DBA if any other tasks occur round that time (1.5 hours before and after) for example, a database backup.
-
If your FNMP server is separate to your database server and your DBA confirms that no other significant process is occurring at that time, check with your network team to see if anything occurs at that time which could interfere with network traffic between the FNMP and database server.
The suggestions above are some common examples but you may have individual systems in your environment that could cause conflict e.g. some Network Security tools can block traffic while they're updating so if they're scheduled to update at the same time as the compliance import then this could occur.
As mentioned previously, in most cases the error is a one-off (a sudden and unexpected drop) and so will work the next time, the steps above are only required if you see the error on several consecutive days.
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Case id: 00001065
Activity: Status change: 2 hours ago