Summary
When trying to import the default packages to IBM Cognos Analytics, it wait with "Unable to connect to remote server" message.Symptoms
During IBM Cognos Analytics installation, the final step is to import the Sample Reports through a the CognosPackageImport.exe import utility.After specifying the Cognos Server and clicking "Install Report Package," the windows immediately displays the following:
Publishing package...
Logging in to Flexera Report Designer (powered by Cognos)...
ManageSoft.Compliance.ComplianceException: FlexNet Manager Platform was unable to log in to the Cognos server. Please make sure that the Dispatcher is up and running at http://CognosServerName:9300/p2pd/servlet/dispatch and that it is configured correctly. ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 10.1.101.76:9300
at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)
--- End of inner exception stack trace ---
at System.Net.HttpWebRequest.GetRequestStream(TransportContext& context)
at System.Net.HttpWebRequest.GetRequestStream()
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at Flexera.CognosPackageImportLogic.CognosConnection.Login(String login)
--- End of inner exception stack trace ---
at Flexera.CognosPackageImportLogic.CognosConnection.Login(String login)
at Flexera.CognosPackageImportLogic.CognosConnection.ImportPackage()
at Flexera.CognosPackageImport.CognosPackageImportMainForm.b__2()
at Flexera.CognosPackageImport.CognosPackageImportMainForm.b__8()
Cause
Importing sample report packages requires access to Cognos' internal Dispatcher web service which runs on port 9300 by default.The above error occurs when either a software or hardware-based firewall blocks the connection.
Resolution
Opened TCP Port 9300 communication from the FlexNet Manager Suite Batch/Application Server towards the Cognos Analytics Server, making sure the Windows Firewall and any network firewalls have this port open.Was this helpful?
Related Articles
Error: Authentication Failed. Message: Unable to connect to the remote server at AppPortal.Business.FSG.FlexeraServiceGate… 21Number of Views Report Designer Cognos reporting package importing fails if Report Designer is running on the different computer from FNMP… 6Number of Views When Importing the Cognos package this fails with "Importing Online Reporting Package Failed" 15Number of Views Handshake failed. Cannot connect to server. No endpoint can establish a connection to the server. 277Number of Views InstallShield Fails to Connect to License Server 13Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago