Summary
Flexnet admin and reporting does not start as a service on RHEL platformSymptoms
1. Install FNMEA 2016 R2 on RHEL Platform.2. Copy the flexnet-service scripts of admin and reporting from ../site to etc/init.d folder.
3. Try to bring up admin, reporting server as service using "flexnet-service start" command.
However the application starts when we run 'flexnet start' from command line.
Cause
Flexnet-service starts as an application not as a service on RHELWorkaround
Follow these steps to install the application as a service.:1) Copy <install dir>/site/server/bin/init.d/wildfly-init.sh to /etc/init.d changing the name to what you want the service to be named (admin and reporting must have different names).
2) Copy <install dir>/site/server/bin/init.d/wildfly.conf to /etc/default changing the name to the <service name>.conf
3) Make the following changes to /etc/init.d/<service name>
? # pidfile: /var/run/wildfly/<service name>.pid
? JBOSS_CONF=?/etc/default/<service name>.conf
4) Make the following changes to /etc/default/<service name>.conf
? JBOSS_PIDFILE=/var/run/wildfly/<service name>.pid
5) Run as Service:
- Run this command from /etc/init.d/chkconfig --add <service name>)
- Run this command from /etc/init.d/./<service name> start
Was this helpful?
Related Articles
Configure a CA Certificate for FlexNet Manager for Engineering Applications Admin and Reporting services 162Number of Views Cognos Test Connection fails if the Admin and reporting services are installed on Linux at default /opt/ location 5Number of Views Flexnet Licensing Service on Reboot doesn't Work in RHEL 7 + SUSE 12 SP4 and Above 8Number of Views FlexNet Manager for Engineering Applications Reporting Server fails to start due to incorrect keystore or truststore passw… 12Number of Views How To: Update agents on machines using the Snow Inventory Service Admin Console 195Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago