Summary
This article discusses how to resolve the issue where assets are not being added or removed from SCCM collections.Symptoms
When new requests are submitted in App Portal, the assets are not being added to the App Portal collections within SCCM.
- The My Requests tab shows the status as "Pending Deployment".
- The CollectionInsert.log files show the insert counts increasing but not getting processed.
- The ESDWebService.log file on the SCCM server has the following error: Error processing insert for Request ID 1000 for collection ID CA100AAA Thread was being aborted.
The same issue could be seen in the CollectionClean.log where assets are not being successfully removed from the collections after requests are processed.
Cause
This issue is caused when a large number of records need to be processed by the App Portal web service and a timeout exception occurs. The timeout exception gets logged in the Event Viewer logs on the SCCM server.
Resolution
This particular issue can be resolved by increasing the execution timeout value (e.g to 6 min) on the SCCM server machine under IIS manager Sites | Default Web Site | ESDWebService | Configuration Editor | system.web/httpRuntime | executionTimeout
Related Articles
Adjust the Execution Timeout for the App Portal website 11Number of Views Scan selected SCCM Collections and Schedule It 6Number of Views Importing computer relationships in App Portal with SCCM 2012 CAS 6Number of Views Issues Resolved in App Portal 2017 R1 10Number of Views Does App Portal return Last Used Date for Asset Intelligence software utilization option in the Inventory Class's Usage Re… 6Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago