Summary
Describe using the /clone_wait switch in InstallShield 2015 SP2 and InstallShield 2016 SP1 and later.
Symptoms
A Setup.exe launcher created by a Basic MSI or InstallScript MSI project waited for the Setup.exe process to complete before return control. In a number of cases such as the command prompt we have been able to identify how unexpected behavior occurs and have suggestions to address the new behavior.
Cause
Due to Setup.exe launcher design change a Setup.exe launcher created from a Basic MSI or InstallScript MSI is intended to use the /clone_wait command line parameter to properly wait on the installation. Starting with the releases of InstallShield 2016 SP1 and InstallShield 2015 SP2 you should now be able to use the /clone_wait parameter.
Steps To Reproduce
Prior to InstallShield 2016 SP1 and InstallShield 2015 SP2, the Setup.exe launcher created by a Basic MSI project did not recognize the switch /clone_wait.Here are some of the known scenarios where the change in behavior has been observed:
Case 1
Launching from command prompt (cmd.exe)
- Build a compressed setup.exe based on a Basic MSI project.
- Open the command prompt and navigate to the directory containing the setup.exe to launch.
Prior to InstallShield 2016 you may have preceded the entire Setup.exe command-line option with start /WAIT. A properly formatted example of this usage is as follows:
C:\>start /WAIT setup.exe /w
Using InstallShield 2015 SP2 or InstallShield 2016 SP1 and beyond use:
C:\> start /WAIT setup.exe /clone_wait
Case 2
LaunchAppAndWait() function from an InstallScript Custom Action
- In your Basic MSI project you include InstallScript code using LaunchAppAndWait() within a compressed setup.exe.
- Using SUPPORTDIR you include the file "singleexe.exe" - this is the payload intended to be launched.
Using InstallShield 2015 SP2 or InstallShield 2016 SP1 and later, the code change when using LaunchAppAndWait() resembles:
STRING szProgram, szCmdLine;
NUMBER nReturn;
szProgram=SUPPORTDIR^"singleexe.exe";
szCmdLine="/clone_wait";
nReturn=LaunchAppAndWait(szProgram, szCmdLine, LAAW_OPTION_WAIT);
Case 3
Launching via a Suite/Advanced UI project
- Build a compressed setup.exe based on a Basic MSI project.
- Include the setup.exe as a package in a Suite/Advanced UI project.
- Add /clone_wait to the EXE Command Line
Resolution
The /clone_wait parameter has been included to work with Basic MSI & InstallScript MSI projects. Using InstallShield 2015 SP2 or InstallShield 2016 SP1 and later will include this updated functionality.
If this issue occurs when using Custom Prerequisites (.prq) then, in the "Application to Run" tab of your prerequisite add /clone_wait to the fields available for specifying command line arguments.
NOTE: For InstallShield 2016, ensure the file version of isdev.exe found in the 'System' directory is equal to or greater than 23.0.0.428. To check the version and find file navigate to:
- C:\Program Files (x86)\InstallShield\2016\System\isdev.exe
- Right click and select Properties
- Select the Details Tab and confirm the 'File Version'
For InstallShield 2015, ensure the file version of isdev.exe found in the 'System' directory is equal to or greater than 22.0.0.401. To check the version and find file navigate to:
- C:\Program Files (x86)\InstallShield\2015\System\isdev.exe
- Right click and select Properties
- Select the Details Tab and confirm the 'File Version'
Additional Information
For more information on the Setup.exe command line parameters for a Basic MSI project, you can look at the following help document, Setup.exe and Update.exe Command-Line Parameters.
LaunchAppAndWait nOptions Parameter When Using InstallShield 2016 SP1
Best Practices to Avoid Windows Setup Launcher Executable Issues
Related KB Articles
LaunchAppAndWait nOptions Parameter When Using InstallShield 2016 SP1
Best Practices to Avoid Windows Setup Launcher Executable Issues
Related Articles
Waiting for Electronic Update to finish on the Core Server in FlexNet Code Insight 3Number of Views Expand Archive (TAR) Action Does Not Wait for Tar Command to Complete 6Number of Views How to Increase the Time an Installer Will Wait for a Windows Service to Stop. 4Number of Views Unable to configure consistent suite recognition when there are multiple suites of the same product and child titles of th… 3Number of Views FlexNet Inventory Agent installation/upgrade may pause for ~10 minutes unnecessarily to allow running agent processes to f… 4Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago