Summary
Access is denied errors are most commonly caused by antivirusSymptoms
Running a pure InsatllScript based installation you see a File Error, ?Access is denied? during the actual installation of the files.
Cause
This error can occur when third party software, mainly anti-virus, hold the .tmp files in use, causing the InstallScript engine to not have access to them. The .tmp files are coming from the InstallScript engine. What actually occurs during installation is a .tmp file is created within the installation location, and then the .tmp file is renamed or expanded to become the target file. Some anti-virus solutions will either hold these files in use, and in some cases delete these files. This behavior also appears to be most common with installations that contain a large number of files.Workaround
There are a few ways that this could ultimately be addressed. The first way would be to alter the default OnFileError event to contain logic that will automatically retry accessing the file. This can add some additional time to the install, but should address the access is denied error. You can refer to the OnFileError_Retry.txt attached to this KB for an example of this modified event.Another longer term solution would be to migrate to a Windows Installer based project type, with Basic MSI being preferred. Since the MSI based installers are processed by Windows Installer the files should not be locked by anti-virus at installation time.
Additional Information
If you are experiencing this error and it has been determined that it is caused by anti-virus, then you will want to contact the anti-virus vendor. Ultimately the issue is with how these third-party applications handle the .tmp files, and would require the vendors to address this with their software. In this regard it is best for you as the customer of the anti-virus to contact the vendor for support, and request them to address the problem.Was this helpful?
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