Summary
When trying to activate an InstallShield installation against a concurrent license server an error is displayed stating "License Error :- -170"Symptoms
When attempting to activate or launch InstallShield with a concurrent license, the following error appears:
"InstallShield could not acquire a license because you are not entitled to use this software. You can try to reestablish the connection or exit InstallShield. Contact your license administrator for details. License error:-170."
Subsequently, the error message may appear as follows:
"The license for InstallShield could not be renewed because you are no longer entitled to use this software. You can try to reestablish the connection or exit InstallShield. Contact your license administrator for details."
"InstallShield cannot contact the FlexNet license server at this time. This may be due to server or network issues. You can try to reestablish the connection or exit InstallShield."
"InstallShield could not acquire a license because you are not entitled to use this software. You can try to reestablish the connection or exit InstallShield. Contact your license administrator for details. License error: -96"
Cause
C. The environment variable on the client machine is not set to connect to the concurrent license server.
Resolution
A. Ensure the connection between the client machine and the license server is established by pinging the server or client IP address/name in the command line (Ex. ping 192.168.0.1 or ping MyServer).
The following error messages indicate a problem with the connection:
"Ping request could not find host [Server/Client machine name or IP Address]. Please check the name and try again."
"Request timed out."
If you encounter these error messages, check if there is an internal problem with the server or client machine. You may need to check with your network administrator if pinging the license server fails as there may be an underlying connection problem between the license server and client machines.
B. Make sure to specify the license server that you are using on the machine where you install InstallShield. Please follow these steps:
For InstallShield 2010 and later:
- Launch InstallShield
- Select the Purchase/Activation option when prompted
- Click on the Browse for corporate license server link in the "Enter Your Serial Number" dialog.
- In the Specify License Server Dialog, enter your license server name or license server IP address in the Server field (ex. MYLICENSESERVER or ex. 192.168.0.1) and leave the Port Field blank.
- Click on Next. If the connection to the license server is successful, the Activation Complete message appears.
For InstallShield 2008 and 2009 Editions:
- Launch InstallShield and click on the "Own" link when the InstallShield splash screen is displayed.
- Click on the Browse for corporate license server link in the "Enter Your Serial Number" dialog.
- In the Specify License Server Dialog, enter your license server name or license server IP address in the Server field (ex.MYLICENSESERVER or ex. 192.168.0.1) and leave the Port Field blank.
- Click on Next. If the connection to the license server is successful, the Activation Complete message appears.
C. Manually configure the environment variable on the system (Windows):
- Close down any open instances of InstallShield.
- Click on the Start Menu and select the Control Panel
- Double click on the System icon and select the Advanced Tab
- Click on Environment Variables
- Under System Variables, click on "New" to create a new System environment variable.
- Under Variable Name, Enter the license file name as follows: mvsn_LICENSE_FILE
- Enter the name of your license server in the Variable Value with a preceding @ character (ex. @MYLICENSESERVER or @mylicenseserver).
- Click OK to apply the changes.
- The variable name of the environment variable must be entered as follows: mvsn_LICENSE_FILE or else InstallShield will not recognize the license server and fail to initialize. For the variable value field, specify the name of the license server following this convention: @MYLICENSESERVER or @mylicenseserver. Make sure to include the preceding "@" character.
- If the system environment variable already exists but the error still persists, ensure that the environment variable value references the appropriate server. Alternatively, the IP address of the license server can be referenced in the Variable Value field as an example: @192.168.0.1
Additional Information
C:\Program Files (x86)\Flexera Software\FlexNet\Licensing Server\logs
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| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
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Case id: 00001065
Activity: Status change: 2 hours ago