Summary
This article covers the issue where the Inventory Beacon cannot download policy due to errors downloading the InventorySettings.xml fileSymptoms
If the inventory beacon fails to download policy, check the BeaconEngine.log and look for an error similar to:2015-09-25 13:14:11,505 [ownload.DownloadClient|policy] [INFO ] Downloading item 'inventory-settings' using URI 'http://<Parent_Server>/inventory-beacons/api/download/inventory-settings'.
2015-09-25 13:14:11,615 [llers.BeaconController|policy] [ERROR] Policy change loading failed.
Flexera.SaaS.Transport.Core.ComplianceApiFatalException: Could not download item from http://<Parent_Server>/inventory-beacons/api/download/inventory-settings. Server returned 'Internal Server Error'
at Flexera.SaaS.Transport.Core.HttpClientBase.HandleDownloadResponse(HttpResponseMessage response, Boolean ignoreNotFound)
at Flexera.SaaS.Transport.Download.DownloadClient.DownloadItem(String itemName, String etagValue, Boolean ignoreNotFound, Dictionary`2 queryList)
at Flexera.SaaS.Transport.Download.PackageDownloader.DownloadAndExtractResource(String resourceId, String outputFolderPath, Boolean ignoreNotFound)
at Flexera.SaaS.Transport.Download.PackageDownloader.DownloadInventorySettings(String configPath)
at Flexera.Beacon.Engine.Controllers.BeaconController.DownloadInventorySettings(Policy policy)
at Flexera.Beacon.Engine.Controllers.BeaconController.PolicyController_PolicyChangeCompleted(Object sender, PolicyEventArgs e)
Cause
On seeing this error you should go to the application server directly and try the following URL on a web browser:http://localhost/inventory-beacons/api/download/inventory-settings
if it displays an error message stating that access to the file %PROGRAMDATA%\Flexera Software\Beacon\InventorySettings\InventorySettings.xml was denied, the issue is due to the IIS application pool user not having the required permissions.
Resolution
To resolve this issue you must ensure that the app pool identity for inventory-beacons in IIS on the application server is in the local administrators group and restart IISWas this helpful?
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Case id: 00001065
Activity: Status change: 2 hours ago