Summary
When trying to connect to a license server from a remote client behind a firewall a -96 error is received and no connection to the license server is made. This results in no valid license for the client.
Symptoms
When trying to connect to a license server from a remote client behind a firewall a -96 error is received and no connection to the license server is made. This results in no valid license for the client.
Cause
The cause of this problem is due to the vendor daemon needing to communicate with the client application (InstallShield or AdminStudio) directly.
Resolution
To resolve the problem a specific port number must be assigned to the vendor daemon. This can be done in 2 ways.
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You can add to the end of the VENDOR / DAEMON line in the license file PORT=xxxxx
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You can if using lmadmin to control your license server(s) set this in the user interface
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Select Administration and then select Vendor Daemon Configuration
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There is a field labeled "Vendor Daemon Port" and here you should select "Use this port" and enter a port number. This port number may need to be assigned to you by your local IT team. See the image below.
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In both cases you will need to have your local IT team open the port you have chosen for bi-directional communication.
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| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
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+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
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Case id: 00001065
Activity: Status change: 2 hours ago