Summary
This article covers the reactivation process for InstallShield 2010 and later versions.
Symptoms
During the launch of the InstallShield 2010 (and later) product, a dialog box is displayed and prompts for the reactivation of the product serial number to verify the license key. Following the on-screen prompts for reactivation fails with an error informing the user with the following error message or similar:
The license key for this computer is in use on another computer.
Error 20653: The number of activations allowed for this account has been exceeded
IMPORTANT: Be aware that the word "Re-activation" in the dialog box is important to this article. For problems regarding activation, please see the other links listed in the Additional Information section below.
Cause
Reactivation of the product occurs periodically without any interaction on your part. Several weeks before reactivation is required, the Activation Wizard sends a reactivation request for your serial number to the Activation Server silently (that is, without displaying any user interface). The server receives the reactivation request, and it validates the request.
- If the reactivation request is valid, the server automatically notifies the Activation Wizard about the status, enabling the wizard to reactivate InstallShield for you.
- If reactivation cannot be automatically performed when needed (for example, if you do not have an Internet connection), the Activation Wizard is displayed when you launch InstallShield. At that point, the Activation Wizard lets you reactivate InstallShield using the same wizard that is used for activation. The wizard first attempts an online reactivation. If online reactivation is unsuccessful, the wizard enables you to use the offline method. The offline activation process for reactivation is the same as that for activation.
Resolution
The steps below should resolve the issue.
- Close InstallShield
- Open up a Command Prompt and change directories to the appropriate default path:
For 64-Bit Machines: The location will be under the Program Files (x86) directory. For example, InstallShield 2013 on a 64-bit machine would be located at C:\Program Files (x86)\InstallShield\2013\SystemInstallShield Version & Edition Path InstallShield 2010 Express/Pro/PremierC:\Program Files\InstallShield\2010\SystemInstallShield 2011 Express/Pro/Premier
C:\Program Files\InstallShield\2011\SystemInstallShield 2012 Express/Pro/PremierC:\Program Files\InstallShield\2012\SystemInstallShield 2012 Spring Express/Pro/PremierC:\Program Files\InstallShield\2012Spring\SystemInstallShield 2013 Express/Pro/PremierC:\Program Files\InstallShield\2013\SystemInstallShield 2014 Express/Pro/PremierC:\Program Files\InstallShield\2014\SystemInstallShield 2015 Express/Pro/PremierC:\Program Files\InstallShield\2015\SystemInstallShield 2016 Express/Pro/PremierC:\Program Files\InstallShield\2016\SystemInstallShield 2018 Express/Pro/Premier C:\Program Files\InstallShield\2018\System - Execute the following command:tsconfig /return
NOTE: Allow access to ports 80, 443 and 8443 to ensure connectivity to our license servers.
- Restart InstallShield and re-activate the product by selecting the Purchase / Activate option and click on the Activate button.
NOTE: If the online return attempt fails, click the Proceed with Offline Verification button to proceed with the offline license return method. Click the Save button and save the License.request file. Create a Revenera Support Ticket in the Support Hub and attach the License.request file. The License.request file is required for the Revenera Support team to generate a License.response file, which should allow you to complete the offline return process.
You can also send it to the automated activations inbox listed in request text InstallShield dialog, oactivations@flexera.com.
If you see the message The product license has been corrupted. You must repair the license before you can continue, contact Revenera Support.
Additional Information
Reactivation is the process by which an activated product is checked to verify that it is still installed according to the InstallShield EULA, and that it has not been activated on more machines than allowed.
Reactivation is required on each machine on which InstallShield has been successfully installed and activated; otherwise, InstallShield stops working.
This resolution is only applicable to errors showing Re-Activation or Reactivate my license in the dialog box when the product is launched. For issues surrounding other activation problems for InstallShield, please see the following references:
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| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago