Symptoms
Up on integration of SSO with FNO, when trying to email licenses from End User Portal, user is being redirected to the SSO login page.
Diagnosis
It's been observed that from End User Portal of FNO when an attempt to email licenses was made, the user get's redirected to SSO login page and following error was thrown in FNO flexnet.log
2022-06-01 10:24:10,565 [default task-38] ERROR (util) [ADMN] SecurityUtil.setupThreadContext()-->Vulnerability Description : EP session should not be allowed to use PP resources:: sessionId = fXXXXXXXXXXXXXXXXXQQ
Solution
The error means if any End User Portal functionality if tries to access Producer Portal resources, it will invalidate the session and because of that user will be redirected to login page.
In other words, When the login context is for End User Portal but the request servlet path is redirected to or contains /operations instead of /operationsportal it leads to session invalidation and hence this error is reported.
So when the redirect URL for email license or Email Content URL was corrected with /operationsportal, user session got validated and user was continue to use the session.
Related Articles
How do I change the location of compliance import logs? 8Number of Views Display the user's Active Directory(AD) display name instead of login ID on the Request Assignment dashboard 9Number of Views How Do I Change My PayPal or Credit Card Details? 4Number of Views How Do I Change My Login Email / User Name? 5Number of Views Portal admin user cannot see portal user role in the End user portal 6Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago