Summary
Windows 8.1 returns the version of Windows 8 and Windows Server 2012 R2 returns the version of Windows Server 2012 in Suite and InstallScript projects.Symptoms
Platform conditions used in a Suite project evaluate incorrectly on Windows 8.1 and Windows Server 2012 R2. The OS Version is evaluated as 6.2 on both Windows 8.1 and Windows Server 2012 R2. This is the OS Version which corresponds to Windows 8 and Windows Server 2012. This causes the installer to behave as if it is running on either Windows 8 or Windows Server 2012.Similarly, in InstallScript projects, the SYSINFO member nISOSL will be incorrectly set to the value ISOSL_WIN8 on Windows 8.1 and Windows Server 2012 R2.
Cause
This is caused by Windows Compatibility.Resolution
In order to resolve the issue, please apply the attached HotFix. In order to apply the HotFix, please follow the steps below:1.) Close the InstallShield 2013 IDE.
2.) Browse to the Support folder in the InstallShield 2013 install location. The default location is:
32 bit operating system:
C:\Program Files\InstallShield\2013\Support
64 bit operating system:
C:\Program Files (x86)\InstallShield\2013\Support
3.) Rename the following files by appending ORIG to their name:
SetupExe.Admin.manifest
SetupExe.Highest.manifest
SetupExe.Invoker.manifest
4.) Copy the attached .zip file to the Support folder and extract it there.
5.) Verify that the three files which were renamed were extracted from the .zip file in the Support folder.
6.) Restart the InstallShield 2013 IDE and rebuild the project.
Additional Information
A new value for the SYSINFO member nISOSL which corresponds to Windows 8.1 and Windows Server 2012 R2 has been included with Service Pack 1 for InstallShield 2013. The value is:ISOSL_WIN81
For more information regarding the operating system version numbers for Windows operating systems, please see this article.
For more information regarding platform conditions in Suite/Advanced UI projects, please see this HelpNet article.
Was this helpful?
Related Articles
Understanding Snow License Manager Windows Server License Calculations - An Example 87Number of Views Error: "The request was aborted: Could not create SSL/TLS secure channel" when calling api.flexera.com from Windows Server… 60Number of Views Logging An InstallScript MSI Project 361Number of Views Certificate error with SVM files on Server 2012 R2 5Number of Views InstallShield Prerequisites for .NET Framework 3.5 SP1 on Windows 7 and Later, Windows Server 2008 R2 and Later 6Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago