Summary
Discussion on cause and resolution for run time error 2602Symptoms
This error occurs at run time and is displayed in the following format:
The [2] table entry '[3]' has no associated entry in the Media table.
This error may occur when running a first time installation or a patch (.msp).
Cause
- The sequence number of a file(s) in the File table exceeds the LastSequence number for an entry in the Media table.
- A patch has been created, but no previous patch GUIDs were specified when creating the patch. Previous patch GUIDs are only required if there have been previous patches already applied to the MSI intended to be updated.
Resolution
Running an MSI File
If the issue is occuring when running a MSI file, validate the MSI.
- Select Build > Validate > Windows 2000 Logo Validation Suite. This displays any validation error that occurs in the MSI package.
Note: To validate a MSI package, the .msi file must be uncompressed on the Disk1 folder. If you cannot see the .msi file in your release folder, rebuild an uncompressed release.
- Once validation is complete, read through each validation error for any reference to the Media table. If there is, look up the displayed ICE error in the InstallShield Knowledge Base or the MSI Help Library. This will provide additional information on how to resolve the validation error.
- Once the validation error is fixed, run the installation again.
Running a Patch
If the issue is occuring when running a patch:
- Using Developer 8 or later InstallShield products:
- Open the Patch Design view.
- Click the appropriate patch configuration and select the Advanced tab.
- In List of Patch GUIDs to Replace field, verify that you have listed the patch GUIDs of any previous patches that may have been applied to the MSI that the current patch will be applied to.
- Open the Patch Design view.
- Using Developer 7.x:
- Select Tools > Patch Wizard.
- Select the Previous Patches dialog.
- In the List of Patch GUIDs to Replace field, verify that you have listed the patch GUIDs of any previous patches that may have been applied to the MSI that the current patch is being applied to.
- Select Tools > Patch Wizard.
Additional Information
For more information on patching, see the InstallShield Help Library topic Patching.
For more information on validation, see the InstallShield Help Library topic Validation Projects.
Error 2602 is documented in the Windows Installer Help Library topic Windows Installer Error Messages.
The Media and File tables are documented in the Windows Installer Help Library topics Media Table and File Table.
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Case id: 00001065
Activity: Status change: 2 hours ago