Issue
- This error message is presented in the Snow Update Service (SUS) logs:
"2015-02-26 20:02:36,501 [8] ERROR SnowSoftware.Update.SoftwareRecognitionData [(null)] - An error occurred while calling web services to retrieve software product updates. System.TimeoutException: The request channel timed out while waiting for a reply after 00:00:59.9980000.
Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout. ---> System.TimeoutException:
The HTTP request to 'https://updates.snowsoftware.com/us/SoftwareRecognitionService.asmx' has exceeded the allotted timeout of 00:01:00. The time allotted to this operation may have been a portion of a longer timeout. ---> System.Net.WebException: The operation has timed out".
Increase the timeout value passed to the call to Request or increase the SendTimeout value on the Binding. The time allotted to this operation may have been a portion of a longer timeout. ---> System.TimeoutException:
The HTTP request to 'https://updates.snowsoftware.com/us/SoftwareRecognitionService.asmx' has exceeded the allotted timeout of 00:01:00. The time allotted to this operation may have been a portion of a longer timeout. ---> System.Net.WebException: The operation has timed out".
Environment
- Snow Update Server (SUS)
Resolution
Option 1
- Resolve this by extending the timeout setting for Snow Update Service (SUS), on the Snow License Manager (SLM) application server.
- Open C:\Program Files\Snow Software\Snow Update Service\SnowSoftware.Update.Service.exe(Config file)
- There are several settings for the timeout: closeTimeout="00:01:00" sendTimeout="00:01:00"
- You can set both times to “00:05:00”, save the file and then restart the Windows service named "Snow Update Service".
- Please note that this change should be performed for the GUI file, also
- The GUI file can be located here C:\Program Files\Snow Software\Snow Update Service\SnowSoftware.Update.Gui.exe.config (please make sure that the Snow Update Service GUI is closed)
Option 2
- The problem can also be an overload of requests on the Snow Update Server Side. In that case, change the time for update requests in Snow Update Service gui.
- The time for SRS updates cannot be changed in the GUI, but must be done directly in the registry. Open regedit and go to the following node:
- HKEY_LOCAL_MACHINE\SOFTWARE\Snow Software\Snow Update Service\SnowSoftwareRecognitionService
- Change the UpdateHour and UpdateMinute from 19.00 to another value.
Cause
- This happens when attempting to download the Snow Update Service (SUS) via an online update.
- It will request the update from the Snow Update Service and then time out.
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