Summary
This article will help to explain the reason for the out of memory error seen when attempting to start FlexNet Operations (FNO).
Symptoms
Whilst starting FlexNet operations from a command prompt the following errors have been observed:
Error occurred during initialization of VM
Could not reserve enough space for object heap
Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
Cause
This error occurs when contiguous memory(A large chunk) cannot be assigned to a particular Java process, in this case FNO. For example a machine may have 8GB of memory but if the system cannot assign 2GB as one large chunk then the errors may be observed.
Resolution
Ensure that memory intensive applications are shutdown before attempting to start the Java process(FNO) again. This should help to ensure that there is a contiguous chunk of memory available for FNO to start.
Related Articles
Could not reserve enough space for object heap 11Number of Views There Is Not Enough Space on Drive C to Extract the Files 13Number of Views Remove stale agent and beacon version packages from the Beacon server 131Number of Views "Error: Could not create Java Virtual Machine" When Launching InstallAnywhere 34Number of Views SRS rules not triggering despite sufficient data to match the rule 88Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago