Summary
When installing an MSI based project that contains a Windows Service with Service Control Manager Recovery Action settings, Windows Installer runtime error, 1939, is raised. This article includes a workaround.Symptoms
When installing an MSI based project that contains a Windows Service with Service Control Manager Recovery Action settings, Windows Installer runtime error, 1939, is raised:
Service '[2]' ([3]) could not be configured. This could be a problem with the package or your permissions. Verify that you have sufficient privileges to configure system services.
Looking at a verbose log of the install shows the 1939 error takes place during the execution of the standard MSI action, ServiceInstall.
Cause
This problem occurs when a Windows Service defined in the InstallShield project is configured with any of the following Service Control Manager (SCM) Recovery Actions:
Restart ServiceReboot Computer
This problem does not occur if the Windows Service SCM Recovery Actions settings contain Run Command or Take No Action.
Note: The ability to configure Windows Service 'Recovery Actions' is supported beginning with Windows Installer 5. Earlier versions of Windows Installer ignore this setting.
Steps To Reproduce
To reproduce this problem, add a Windows Service with SCM Recovery Actions Restart Service or Reboot Computer:
-
Using the InstallShield Development Environment, open a Basic MSI or InstallScript project under the Installation Designer tab.
-
Add a Component
-
In the View List under Organization, click Setup Design.
- In the Setup Design explorer, right-click a feature
-
Give the component a name
-
-
Add a Windows Service executable file to the Component
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Expand the component, and select the item labeled Files
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In the right pane, right click and from the pop-up menu, select Add....
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Browse to the Windows Service Executable, and click the Open button.
-
Once the file is added, in the right pane, right click on the file, and from the pop-up menu, select Set Key File
-
-
Define the Service
-
In the middle pane, expand the Component's Advanced Settings.
-
Right click the Services item, and from the pop-up menu, select Add Service
-
-
Define the Recovery Actions
-
In the middle pane, select the newly added service
-
In the right pane, go to the Configure Settings section and click on the row labeled Recovery Actions
-
To add an action, on the far right of the row, click the 'Green Plus Sign' icon
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Click on the row labeled SCM Actions
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To add an action, on the far right of the row, click the 'Green Plus Sign' icon
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Set the SCM Action Type to Restart Services or Reboot Computer
-
-
Build and install the Installation Package
Workaround
A possible workaround is to remove the SCM Recovery Actions from the Service configuration and add a Custom Action to launch the SC.exe utility to add the Recovery Actions to the Service.
A sample implementation of this workaround is as follows:
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In the Organization->Components view, remove the Service's SCM Actions of Type Restart Service or Reboot Computer
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In the Behavior and Logic->Custom Actions and Sequences view, add a Custom Action of type EXE, Path referencing a directory.
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Make the following settings to the Custom Action:
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Working Directory = SystemFolder
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Filename & Command line = sc failure "My Service Name" reset= 0 actions= restart/60000
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Return Processing = Synchronous (Check exit code)
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In-Script Execution = Deferred Execution in System Context
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Install Exec Sequence = After MsiConfigureServices
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Install Exec Condition = Not Installed
-
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Rebuild the project
Additional Information
This problem is being tracked internally with issue number IOA-000068608.
For more information, please refer to the following Windows Installer articles:
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