Summary
Computer inventory from Inventory Manager only shows generic Linux versions, for example...Symptoms
Computer inventory from Inventory Manager only shows generic Linux versions, for example:
Red Hat Enterprise Linux Advanced Platform
Whereas it should have something like "Red Hat Enterprise Linux Advanced Platform 5.7" or something similar, why is this?
Cause
The problem is under Inventory Manager Server(IM) resolver when we resolve the ndi files, there is an ?OSNameMap.txt? file under ? C:\Program Files (x86)\ManageSoft\Reporter? folder, this file maps more specific names, release and updates to simpler names.
For instance, the line ?^Red\sHat.* Red Hat Linux? causes an "MGS_OperatingSystem", "Caption" attribute of "Red Hat Enterprise Linux ES release 4 (Nahant Update 6)? to become ?Red Hat Linux? when a .ndi file is resolved into the Inventory Manager database. The full ?MGS_OperatingSystem? class is shown below.
<Hardware Class="MGS_OperatingSystem" Name="Linux" Evidence="OS API">
<Property Name="CSName" Value="bbrhel46x64"/>
<Property Name="Caption" Value="Red Hat Enterprise Linux ES release 4 (Nahant Update 6)"/>
<Property Name="FreePhysicalMemory" Value="69188"/>
<Property Name="FreeVirtualMemory" Value="650416"/>
<Property Name="Kernel" Value="Linux"/>
<Property Name="KernelRelease" Value="2.6.9-67.EL"/>
<Property Name="LastBootUpTime" Value="20131115T123243Z"/>
<Property Name="Manufacturer" Value="Red Hat"/>
<Property Name="Name" Value="RedHatEnterpriseES"/>
<Property Name="OSArchitecture" Value="64-bit"/>
<Property Name="OSType" Value="36"/>
<Property Name="TotalVirtualMemorySize" Value="650624"/>
<Property Name="TotalVisibleMemorySize" Value="509460"/>
<Property Name="Version" Value="4"/>
</Hardware>
<Property Name="CSName" Value="bbrhel46x64"/>
<Property Name="Caption" Value="Red Hat Enterprise Linux ES release 4 (Nahant Update 6)"/>
<Property Name="FreePhysicalMemory" Value="69188"/>
<Property Name="FreeVirtualMemory" Value="650416"/>
<Property Name="Kernel" Value="Linux"/>
<Property Name="KernelRelease" Value="2.6.9-67.EL"/>
<Property Name="LastBootUpTime" Value="20131115T123243Z"/>
<Property Name="Manufacturer" Value="Red Hat"/>
<Property Name="Name" Value="RedHatEnterpriseES"/>
<Property Name="OSArchitecture" Value="64-bit"/>
<Property Name="OSType" Value="36"/>
<Property Name="TotalVirtualMemorySize" Value="650624"/>
<Property Name="TotalVisibleMemorySize" Value="509460"/>
<Property Name="Version" Value="4"/>
</Hardware>
Resolution
To resolve this problem, you can manually change that OSNameMap.txt, for instance, remove the line ?^Red\sHat.* Red Hat Linux?, then you will need to re-generate and resolve all .ndi inventory files again from the Linux etc managed devices. Once the details of WMI data was written into Database, then FNMP need re-import them from IM using the compliance import. After that, the content team will need more detailed WMI evidence entries into a link to the RedHat OS softwaretitle with good version and edition.
When you have the new entries from the dbo.WMIEvidence database table, send them to the content team using the instructions in Q203057 (linked to this article).
Additional Information
Be careful changing OSNameMap.txt. It would be best to not remove the ?([^|]*)\|.* $1 # Remove text after | (e.g. Windows 2K)? line for Windows, for example.
You can safely remove the Fedora, Red Hat, Mac OS X, SuSE however. If you're unsure, please contact Support before making any changes.
Was this helpful?
Related Articles
Docker agent inappropriately runs and crashes on RedHat Enterprise Linux 6 systems 4Number of Views FlexNet Code Insight 2018 R3 cannot get updated openfile limits during installation on RedHat 7 3Number of Views Red Hat Enterprise Server and SuSE Enterprise commercial OS are missing in the Application tab of the Inventory devices 21Number of Views Agent installer for Debian Linux OS is not downloadable from Web UI 19Number of Views IncludeRegistryKey parameter in FlexNet inventory agent (Windows, UNIX, Linux, Mac OS X) 5Number of Views
Revenera Assistant
Online
Hi, I am Reva - Ask me anything.
Updates
No new updates
Chat
Home
Updates
/**/
Thanks for the feedback!
Your feedback has been saved.Rate this response:
1
2
3
4
5
Add Additional feedback ( Optional )
0/240
English
English
Language changed successfully
Something went wrong
Email sent successfully
Something went wrong
Case create successfully
Are you sure you want to cancel
the case creation?
Please select a product to submit the case.
Please select a product version to submit the case.
0/255
Upload Attachment
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to cancel the case creation?
Case closed successfully
File Upload
Maximum file size allowed is 3 MB.
File type not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
File Upload
Maximum file
size allowed is 3 MB.
File type
not supported.
Supported file types:
Documents (.txt, .doc, .docx, .pdf), Images (.jpg, .png), Comma Separated Files
(.csv) Speadsheets (.xlsx, .xls)
© 2026 Flexera Software. All Rights Reserved.
Case id: 00001065
Activity: Status change: 2 hours ago