Summary
This is usually an initialization error that occurs before any installation dialogs appear. This error is usually machine specific and is caused by either not enough permissions or by a break in one of the COM components on your machine.Symptoms
When trying to install an application, you receive one of the following errors or something similar:
- Setup failed to launch installation engine. Server execution failed.
- InstallShield engine (iKernel.exe) could not be launched. Server execution failed.
- Error extracting support files: Server execution failed.
Cause
This is usually an initialization error that occurs before any installation dialogs appear. This error is usually machine specific and is caused by either not enough permissions or by a break in one of the COM components on your machine.Resolution
This error may occur if an install or uninstall that prompted for a reboot was suppressed (i.e., "No, I will restart my computer later" was selected); thus, it did not completely finish. This may conflict if another install is run. To avoid receiving this error, always choose to following option when prompted for a reboot at the end of a installation:
"Yes, I want to restart my computer now."
After the reboot, continue with any other installs or uninstalls, and you should not receive this error. If this error occurs even after selecting Yes to the reboot prompt, Install the iKernel Engine Update. This ensures that the InstallShield engine files are correctly installed on your system, as this can be another cause of the error.
Because this is usually a machine-specific issue, there is no single resolution for this error. Usually one of the following suggestions, or a combination of, address the issue:
Does Your Issue Still Exist?
If after following these instructions your product failed to install, you'll need to contact your vendor. See the Who to Contact page for more information.
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Case id: 00001065
Activity: Status change: 2 hours ago