Summary
No response received during creation of catalog during sync between App Broker and ServiceNow.Symptoms
When attempting to sync the App Broker catalog with ServiceNow you do not see any App Broker catalog items appear within ServiceNow. With verbose logging enabled the ServiceNowIntegration.Log may contain something similar to the below:Failed to update the catalog, Catalog details:8(Google Chrome (x64) 57.0.2987.1333) No response recieved during creation of catalog in ServiceNow.. at AppPortal.Infrastructure.Services.ServiceNowService.CreateServiceNowCatalog(Int32 packageId, String variableSetId) at AppPortal.Infrastructure.Services.ServiceNowService.SyncCatalogsInToServiceNow()
Cause
This issue is related to a ServiceNow setting which either permits or denies SOAP Responses which are not qualified. The setting can be located in ServiceNow by navigating to Web Servers > Web Services as shown below:The issue is currently being tracked by Flexera's Development Team under issue #IOJ-1883927.
Resolution
To resolve this issue the checkbox shown in the screenshot above can be deselected and then perform a restart of the ESD Service on the App Broker Server. However in some environments there may be other applications which rely on this setting remaining checked. If you are not able to un-check this setting you can proceed with the work-around below.Workaround
If you are unable to deselect the check box noted above then a HotFix will be required. The only versions of App Broker which the HotFix can be applied to are App Broker 2017 R2 SP1 and 2018 R1.In order to apply the HotFix download the zip file from the attachments section of this article. The zip file contains two sub-folders, 2018R1 and 2017R2SP1, which contain the patched files for their respective versions. Back up the following files at each location below based on the version of App Broker you are using:
- AppPortal.Business.dll (2018R1 and 2017 R2 SP1)
- AppPortal.Infrastructure.Repositories.dll (2018R1 only)
- AppPortal.Infrastructure.Services.dll (2018R1 only)
- HtmlAgilityPack.dll (2018R1 only)
...Flexera Software\App Portal\Service
...\Flexera Software\App Portal\Web\bin
...\Flexera Software\App Portal\Utilities\MyApps
Then proceed with the steps below:
- Stop the ESD Service on the App Broker Server.
- Extract the contents of the zip file to a staging directory.
- Copy the patched files for the desired version to the App Broker installation directory.
- Start the ESD Service.
- Launch the admin page of the App Broker Site.
- Navigate to Site Management > ITSM Integration
- Click on the 'Configuration' hyperlink for any ServiceNow system.
- Append the following to the end of the URL: &elementFormDefault=qualified
- Click Test and Save.
- Repeat steps 6-9 for each ServiceNow system in the ITSM Integration view.
Additional Information
Configuring SOAP Requests to Return Qualified ResponsesWas this helpful?
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Case id: 00001065
Activity: Status change: 2 hours ago