Summary
In the Helsinki release of ServiceNow, it is necessary to set the glide.wsdl.schema.UnqualifiedElementFormDefault attribute setting to False. If not set, then catalog items will not be imported.Symptoms
When using the Helsinki release of ServiceNow, the catalog item import fails with App Broker. The following error is seen in ServiceNowIntegration.logUnable to find Variable Set Id in ServiceNow to apply default Question to Catalog Items, Variable Set Name:App Portal Variable Set Please verify in ServiceNow Instance
Cause
In the Helsinki release of ServiceNow, it is necessary to set the glide.wsdl.schema.UnqualifiedElementFormDefault attribute setting to False. If not set, then catalog items will not be imported.Resolution
In order to integrate App Broker with the Helsinki release of ServiceNow, you need to open your ServiceNow instance, enter Web Services in the Search box to open the Web Services page, and set the glide.wsdl.schema.UnqualifiedElementFormDefault attribute setting to False. To set this attribute to False, make sure that the Yes | No checkbox under the description of this property is not selected. Alternatively, you could right-click on the property description on this page and select Edit Property from the shortcut menu to open the System Property - glide.wsdl.schema.UnqualifiedElementFormDefault page, and then enter false in the Value field and click Update.Additional Information
See Importing Catalog Items into ServiceNow in the App Portal Administration Guide for additional information on importing catalog items.See Supported ServiceNow Interfaces for a listing of supported ServiceNow interfaces.
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