Summary
When the Agent attempts to download the default machine schedule a "Download failure: 404 Network error" error is present in the Agent Installation log.
Symptoms
After the Flexnet Agent has been installed on the client, it may fail when downloading the default machine schedule with the error message below
Extract from the Installation.log
"<DateTimeStamp>Download failure: 404 Network error
?https://<MachineName>/ManageSoftDL/Schedules/Default Machine Schedule/Default Machine Schedule.osd? to ?C:\Users\<AccountName>\AppData\Local\Temp\NDL7269.osd?
<DateTimeStamp> Download failure: 404 Network error"
Cause
There are several causes that can produce this error message, the resolution section of this article contains the items that commonly cause this error message.
Resolution
The following items are common causes of this error message:
1: If the Beacon is on the application server, the "Local Web Server" setting in the Beacon UI needs to be set to IIS. Note that it is highly recommended to install Beacon on a separate server as there could be potential conflicts with the application server. Selecting IIS also re-configures the IIS Applications if there has been any corruption.
2: Check the account that is running the Flexnet Beacon Engine Service. Try to run as "Local System Account" (which is the default) or change to the Service account.
3: Check if Migration Mode is enabled. This can be verified by selecting "Discovery and inventory" > "Settings" in the web UI.
4: Are there any firewalls or network restrictions such as a proxy that could be restricting access? The URL from the Installation.log can be used in a web browser on the Agent machine and the Beacon machine to verify if the machines can communicate.
5: Verify the Beacon is downloading its policy by reviewing the BeaconEngine.log, the default location for this log file is: "C:\ProgramData\Flexera Software\Compliance\Logging\BeaconEngine."
6: Lastly, verify that .Net Framework has been registered on the Beacon system, if unsure re-register .Net.
Additional Information
The download error above also applies to the download of policy on the agent.
Related Articles
HOTFIX: Install Fails With Error 1001 When a .NET Installer Class Component is Present in InstallShield 2015 SP1 17Number of Views Offline activation failed with error 51306, 51309 (FLX_ACT_TRAN_ERR_RSP_SIGNATURE_*) 45Number of Views ERROR: Need LFS Connection to Move Ahead. Please Make Sure The LFS URL is Present in The Configuration 10Number of Views Unable To Install Snow Inventory Agent - Network Resource Unavailable - CCMCache Error 58Number of Views Prerequisite failed to install with error "The feature you are trying to use is on a network resource that is unavailable. 28Number of Views
Hi, I am Reva - Ask me anything.
No new updates
Thanks for the feedback!
Your feedback has been saved.Rate this response:
Add Additional feedback ( Optional )
Are you sure you want to cancel
the case creation?
Are you sure you want to cancel the case creation?
Are you sure you want to close this case
| Products | Region | Phone Numbers |
|---|---|---|
| FlexNet Operations FlexNet Embedded FlexNet Publisher FlexNet Connect FlexNet Code Insight InstallAnywhere InstallShield |
North America * |
+1 630-332-2513 (toll) +1 877-279-2853 (toll-free in North America) |
| Europe * |
+44 1925 944367 (toll) +44 800 047 8642 (toll-free in Europe) |
|
| Japan * | +81 3-4540-5335 (select option 2) | |
| Australia * |
+61 3 9895 2177 +61 1800 560 603 (toll-free in Australia) |
|
|
Usage Intelligence (formerly
Revulytics) Compliance Intelligence |
Please use the Case Portal to submit your support ticket or reach out to your Revenera contact. | |
Case id: 00001065
Activity: Status change: 2 hours ago