Summary
This error is usually a machine-specific issue and can be related to a corrupted registry key or a DCOM error.Symptoms
When trying to install an application, you receive one of the following errors or something similar:
- An installation support file could not be installed. The specified module could not be found.
- Error extracting support files: The specified module could not be found.
- The InstallShield engine (ikernel.exe) could not be launched. Wrong module kind for the operation.
- One or more files did not properly self-register MyFile.dll: The specified module could not be found.
Cause
This error is usually a machine-specific issue and can be related to a DCOM error.Resolution
This error might be related to a DCOM error. Updating your system can help resolve issues with DCOM.
If this error occurs in conjunction with a self-registration error, such as the one below, it is recommended that you contact your software vendor with file name that failed to register.
One or more files did not properly self-register MyFile.dll: The specified module could not be found.
Most self-registration errors occur with files that are specific to the application you are trying to install that the software vendor will have more information about.
This error may also be resolved with general troubleshooting steps. For example:
- Install the Latest Ikernel engine
- Clean the Temp Directory
- Acquire Administrative Privileges on Your Computer
- Close Applications Running in the Background
- Detect and End Previously Running Installation Processes
Does Your Issue Still Exist?
If after following these instructions your product failed to install, you'll need to contact your vendor. See the Who to Contact page for more information.
Related KB Articles
Q108373Q108222
Q108211
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Case id: 00001065
Activity: Status change: 2 hours ago